Naming Conventions
Since Blueprint automatically generates the code for the CDL circuitry, it has to auto-generate names. Since names can be reused in several places in different ways Blueprint has to be able to generate unique names and since they are to be seen by the coder they must be meaningful. Thus the auto-generated names tend to become long, containing the parentage, user name and object type. In the case of connections they can contain the names/types of objects at both ends and since there could be multiple connections between these objects, they will contain index numbers as well.
To make life easier for programmers it is therefore good practice to specify short names and to use abbreviations wherever possible.
For stores and interfaces use 'noun' names - 'Tracks' (Trks), 'Beams', 'Control' (Ctrl)
For methods and threads use 'verbs' - 'Filter', 'Compress', 'Detect'
Collectors, distributers etc route events through the system and can combine several event types from/to several objects. It therefore common to name them in relation to the object they are most associated with. Ie distributers usually distribute a data store, collectors are collecting for a method. When this is not the case an appropriate meaning name can be derived from what the object actually does (distributing all of the collected input data).
Pin connections are a bit harder, they could be connected to stores or methods. So say what a pin does, 'Tick', 'Update', 'Reset', 'ModifiedBeams' (obviously output if its a Beam Modifier circuit). Dont use words like 'input'/'output', as they could be verbs or nouns which can invert their meaning or can depend on the readers perspective - "Place your input here":input, "Here is my input to your report":output.
When using multiple words capitalize each word eg. 'Filter Coefficients' (FltCoeffs). Similarly for common acronyms use capitalized forms eg. FFT (Fast Fourier Transform) , use Fft. This allows them to be linked with other words and wont be confused with defined constants (usually in UPPERCASE).
Don't use waffle or generic terms
NewCarDataFromDetector - we know its new, its a TST, and we can see where its come from
Process - we know its a process, it's a Thread, what does it do ?
Data - we know its data, what does it describe ?
Store - we know its a store, what is it for ?